collapse

* Benutzer Info

 
 
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?

* Wer ist Online

  • Punkt Gäste: 56
  • Punkt Versteckte: 0
  • Punkt Mitglieder: 1
  • Punkt Benutzer Online:

* Forenstatistik

  • stats Mitglieder insgesamt: 14038
  • stats Beiträge insgesamt: 67226
  • stats Themen insgesamt: 9067
  • stats Kategorien insgesamt: 5
  • stats Boards insgesamt: 17
  • stats Am meisten online: 415

Autor Thema: Fehler nach Aktualisierung '..enhält Automatisierungsobjekt Date nicht'  (Gelesen 316 mal)

Offline thoco

  • Newbie
  • Beiträge: 12
Hallo Zusammen,
ich habe meine Datenbank in Access 2016 berarbeitet und wieder auf die Rechner der Mitarbeiter mit Access 2010 gespielt. Jetzt gibt es aber bei 2 von 5 Rechnern eine Fehlermeldung in einem Formular das ich nicht bearbeitet habe.

In diesem Formular sind Vorgänge mit Rückrufterminen aufgeführt. Möchte man diese nun aufsteigend sortieren erscheint folgende Fehlermeldung: "Das Objekt enthält das Automatisierungsobjekt 'Date' nicht.
Sie haben versucht, eine Visual Basic Prozedur auszuführen, um eine Eigenschaft oder Methode des Objekts einzustellen.
Die Komponente stellt jedoch die Eigenschaft bzw. Methode nicht für die Automatisierungsvorgänge zur Verfügung."

Auch die bedingte Formatierung in diesem Formular funktioniert nicht mehr, diese sollte abgelaufene Termine in rot schreiben.
Auch der E-Mail-Versand funktioniert nicht mehr richtig "Laufzeitfehler '3085' Undefinierte Funktion Format in Ausdruck".

Nutze ich die zuletzt verwendete Datenbank, bevor ich diese aktualisert habe, funktioniert alles wieder.

Hat jemand eine Idee, woran das liegen könnte. Vor allem, warum der Fehler dann nicht bei allen Rechnern auftaucht?

Danke für Rückmeldungen.
 

Offline MzKlMu

  • Moderator
  • Access-Oberguru
  • *****
  • Beiträge: 7376
Hallo,
prüfe und vergleiche im VBA Editor unter dem Menüpunkt "Extras" die Verweise.
Gruß
Klaus
 

Offline DF6GL

  • Global Moderator
  • Access-Oberguru
  • *****
  • Beiträge: 23414
Hallo,

zudem sollte die DB, wenn sie auf A2010 ablaufen soll, auch mit A2010 debuggt/kompiliert werden, und vice versa.



Offline Lachtaube

  • Access Guru
  • ****
  • Beiträge: 1295
Welche Spracheinstellungen werden/wurden verwendet? Spielt Dir vielleicht die Objektnamen-Autokorrektur ein Schnäppchen? Sind alle VBA-Verweise im grünen Bereich?
Grüße von der (⌒▽⌒)
 

Offline thoco

  • Newbie
  • Beiträge: 12
Super, läuft wieder.