collapse

* Benutzer Info

 
 
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?

* Wer ist Online

  • Punkt Gäste: 84
  • Punkt Versteckte: 0
  • Punkt Mitglieder: 0

Es sind keine Mitglieder online.

* Forenstatistik

  • stats Mitglieder insgesamt: 14160
  • stats Beiträge insgesamt: 68645
  • stats Themen insgesamt: 9248
  • stats Kategorien insgesamt: 5
  • stats Boards insgesamt: 17
  • stats Am meisten online: 415

Autor Thema: DB Absichern klappt nicht richtig  (Gelesen 4152 mal)

Offline ThomM

  • Access-User
  • *
  • Beiträge: 53
DB Absichern klappt nicht richtig
« am: Mai 06, 2010, 08:00:13 »
Moin zusammen.

Wieder mal habe ich ein 'kleines' Problem.

Ich habe meine DB nach dieser Anleitung http://www.team-moeller.de/?Tipps_und_Tricks:Datenbanken_schuetzen#Sicherheitssystem abgesichert.
Das ganze klappt auch ganz gut auf dem Rechner, auf dem ich diese DB erstellt habe.

Wenn ich aber nun diese DB auf einem anderen Rechner, auf dem sich nur die Originale, unmodifizierte  system.mdw befindet, öffne, startet diese ganz normal ohne das Sicherheitssystem und ich bin als 'Admin' mit allen Rechten eingeloggt.

Ich habe diese ganze Aktion dann nochmal gemacht, mit dem gleichen Ergebnis.

Hat jemand ne Idee, was da falsch läufen könnte?

 

Offline DF6GL

  • Global Moderator
  • Access-Oberguru
  • *****
  • Beiträge: 23531
Re: DB Absichern klappt nicht richtig
« Antwort #1 am: Mai 06, 2010, 09:05:23 »
Hallo,

vermutlich hast Du Dich doch nicht genau an die Anleitung gehalten und dieses:

Zitat
Entfernen Sie den Benutzer "Administrator" aus der Gruppe "Administratoren".

wohl nicht gemacht...


Offline ThomM

  • Access-User
  • *
  • Beiträge: 53
Re: DB Absichern klappt nicht richtig
« Antwort #2 am: Mai 06, 2010, 09:55:05 »
... doch, habe ich.

Was mich etwas wundert: es gibt in der Liste der User einen, der 'Administrator'  heisst, aber keinen der 'Admin' heisst.
Wenn ich die DB auf einem Rechner mit nicht modifizierter system.mdw starte gibt mir CurrenUser zurück, dass ich als 'Admin' angemeldet bin.

Ich habe dann versucht einen User 'Admin' anzulegen um Ihm Rechte zu entziehen, was aber misslang, weil er schon existiert.  >:(
Löschen lässte er sich ja leider auch nicht...

Bei der Rechtevergabe habe ich den User 'Administrator' aus der Gruppe der Admins entfernt und ihm zusätzlich nochmal in den Benutzerrechten alle Rechte entzogen.

bin etwas hilflos...
 

Offline MzKlMu

  • Moderator
  • Access-Oberguru
  • *****
  • Beiträge: 7535
Re: DB Absichern klappt nicht richtig
« Antwort #3 am: Mai 06, 2010, 10:07:34 »
Hallo,
hast Du die System.Mdw modifiziert, oder eine eigene MDW erstellt?
Die System.mdw bleibt unangetastet. Du musst eine eigen MDW erstellen. Dann musst Du dieser MDW beitreten. Dann eine neue DB anlegen und alle Objekte aus der ungesicherten DB importieren. Rechte entziehen wie beschrieben.
Dann trittst Du wieder der System.Mdw bei. Die gesicherte DB darf sich jetzt nicht mit einem Doppelklick öffnen lassen.
Gestartet wird die gesicherte DB mit einer Windowsverknüpfung in der die richtige MDW mitgegeben wird.
Hier nioch weitere Infos:
Bedienungsanleitung: Aktivieren des Sicherungssystems durch Erstellen einer Arbeitsgruppendatei
Sicherheitssystem

Zur Beachtung: Die Anleitung ist exakt zu beachten und sorgfältig umzusetzen.
Gruß
Klaus
 

Offline ThomM

  • Access-User
  • *
  • Beiträge: 53
Re: DB Absichern klappt nicht richtig
« Antwort #4 am: Mai 06, 2010, 10:24:07 »
so, habe den Fehler gefunden:

Was in meiner Anleitung nicht stand: Ich musste der Gruppe 'Benutzer' alle Rechte nehmen und meine User in eine neu erstellte Gruppe packen, in der das Admin-Konto nicht vertreten ist.
Somit kann ich die DB nicht mehr mit einer 'frischen' system.mdw öffen  ;D

Endlich.. danke euch für die Hilfestellung

Grüsse, Thomas
 

 

Kann aktuellen DS nicht drucken

Begonnen von cyco7Board Formular

Antworten: 8
Aufrufe: 3971
Letzter Beitrag Juli 17, 2011, 16:49:03
von TMC
Objekterstellung durch ActivX-Komponente nicht möglich

Begonnen von -Tom-Board Access Programmierung

Antworten: 6
Aufrufe: 6385
Letzter Beitrag März 04, 2011, 19:29:49
von database
Kunden auslesen, welche nicht ware von einem Lieferanten bekommen haben.

Begonnen von GuidoBoard Tabelle/Abfrage

Antworten: 9
Aufrufe: 6731
Letzter Beitrag Mai 11, 2010, 10:35:10
von Guido
Objekt Date and Time Picker wird nicht erkannt

Begonnen von Muhtar99Board Access-Hilfe

Antworten: 2
Aufrufe: 5935
Letzter Beitrag Mai 12, 2010, 08:07:43
von Muhtar99
Datensatz automatisch löschen, wenn Bedingung nicht erfüllt

Begonnen von KnatterkopfBoard Formular

Antworten: 4
Aufrufe: 4079
Letzter Beitrag Mai 14, 2010, 16:24:54
von Knatterkopf