collapse

* Benutzer Info

 
 
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?

* Wer ist Online

  • Punkt Gäste: 59
  • Punkt Versteckte: 1
  • Punkt Mitglieder: 1

Es sind keine Mitglieder online.

* Forenstatistik

  • stats Mitglieder insgesamt: 13914
  • stats Beiträge insgesamt: 65797
  • stats Themen insgesamt: 8880
  • stats Kategorien insgesamt: 5
  • stats Boards insgesamt: 17
  • stats Am meisten online: 415

Autor Thema: Syntaxfehler bei Anlegen eine neuen Datensatzes in UNterformular  (Gelesen 3546 mal)

Guido

  • Gast
Acces 07

ich habe vor zwei JAhren eine kleine Datenbank mit einem Bestellwesen erstellt.

Hier habe ich ein Formular"Kundeneingabe" mit einem Unterformular "Auftrag" mit wieder einem Unterformular"Auftragsdetails".

seit kurzem kommt nun beim Anlegen eines Datensatzes im Unter/Unterformular "Auftragsdetails" die MSGbox von Access "Syntaxfehler.
Bisher ging es jetzt plötzlich nicht mehr.

an was kann das liegen.
 

Offline MzKlMu

  • Moderator
  • Access-Oberguru
  • *****
  • Beiträge: 7202
Hallo,
da steht ja bestimmt nicht nur Syntaxfehler, sondern noch weiterer Text. Bitte zitieren.
Außerdem sind die Hinweise zur Fehlersuche mehr als dürftig.
Wie wird denn der neue Datensatz angelegt?
Gebundenen Formulare?
Gruß
Klaus
 

Offline Guido

  • Newbie
  • Beiträge: 2
Sorry waren wohl zu wenig informationen.
 bei mir sieht das ganze so aus.



das Hauptformular hat die Daten Deer Kundestammdatei
das Unterfromaular Auftrag ist verbunden bzw. verknüpft über die Kundennummer in der Tab Auftrag.
Das U-Formular Auftragsdetail ist verknüpft über die Auftragsnummer.

jetzt kommt bei Eingabe der Anzahl oder eines anderen Feldes in dem Unterformular der Fehler "Syntaxfehler" also dann, wenn es den Datensatz anlegt.
leider steht nicht mehr da sorry. siehe auch Bild.
Anfangs hat es wunderbar geklappt. und plötzlich nicht mehr.

Bitte um Hilfe
 

Offline DF6GL

  • Global Moderator
  • Access-Oberguru
  • *****
  • Beiträge: 23265
Hallo,

gibt es (VBA-) Code (oder auch Makros) in der DB?

sind die Verweise (noch) in Ordnung?

stimmen die Angaben in den Verknüpfungsfeldern, und in den Steuerelementinhalten der Formular-Felder?


Notfalls neue leere DB anlegen und alles aus der alten importieren.