collapse

* Benutzer Info

 
 
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?

* Wer ist Online

  • Punkt Gäste: 90
  • Punkt Versteckte: 0
  • Punkt Mitglieder: 1
  • Punkt Benutzer Online:

* Forenstatistik

  • stats Mitglieder insgesamt: 14129
  • stats Beiträge insgesamt: 68309
  • stats Themen insgesamt: 9200
  • stats Kategorien insgesamt: 5
  • stats Boards insgesamt: 17
  • stats Am meisten online: 415

Autor Thema: (Me!Bemerkung = Null) setzt Cursor nicht an Anfang des Memo-Feldes  (Gelesen 1655 mal)

Offline hawebe

  • Access-User
  • *
  • Beiträge: 98
Hallo,
bei Überarbeitung eines Kundengebotes lösche ich den Feldinhalt eines Memo-Feldes: Me!Bemerkung = Null.

Neue Textbausteine setze ich wie folgt:

If Nz(Me!AngebBemerkung, "") = "" Then
   Me!AngebBemerkung = "Wegen der Überarbeitung Ihrer Druckvorlage fallen Grafikkosten an."
Else
   Me!AngebBemerkung = Me![AngebBemerkung] & vbCrLf & "Wegen der Überarbeitung Ihrer Druckvorlage fallen Grafikkosten an."
End If

Der erste neue Textbaustein wird jedoch nicht an den Anfang des Feldes, sondern in die 2. Zeile gesetzt.
Könnt Ihr mir bitte sagen wie ich den ersten Textbaustein in die erste Zeile bekomme.
Gruß aus dem Emsland
 

Offline DF6GL

  • Global Moderator
  • Access-Oberguru
  • *****
  • Beiträge: 23508
Re: (Me!Bemerkung = Null) setzt Cursor nicht an Anfang des Memo-Feldes
« Antwort #1 am: Dezember 26, 2013, 14:37:52 »
Hallo,

mhmm,  durchblicke jetzt nicht die Situation und die Logik...



Egal, ob  das Memofeld anfänglich auf Null gesetzt wird oder nicht, bräuchte der gesamte Code auch nur so aussehen, wenn bei vorausgegangenen Zuweisungen an das Memofeld auch immer ein vbCrLf  angehängt wird:

Me!AngebBemerkung = Null
Me!AngebBemerkung ="Das ist die erste Zeile" & vbCrLf

Me!AngebBemerkung = Me![AngebBemerkung] & "2. Zeile: Wegen der Überarbeitung Ihrer Druckvorlage fallen Grafikkosten an." & vbCrLf

Me!AngebBemerkung = Me![AngebBemerkung] & "Das ist die 3. Zeile." & vbCrLf

Offline hawebe

  • Access-User
  • *
  • Beiträge: 98
Re: (Me!Bemerkung = Null) setzt Cursor nicht an Anfang des Memo-Feldes
« Antwort #2 am: Dezember 26, 2013, 15:49:07 »
Hallo Franz,

danke für die einfache und problemlos laufende Variante.

Ich wünsche Dir noch einen angenehmen 2. Feiertag und einen guten Rutsch in das kommende neue Jahr.
Gruß aus dem Emsland
 

 

Textfleder beim Öffnen auf Null setzen

Begonnen von LalikowskiBoard Formular

Antworten: 8
Aufrufe: 9395
Letzter Beitrag November 19, 2010, 10:40:38
von MzKlMu
Keine Anzeige von negativen Gehältern -->Anzeige als Null?

Begonnen von MakBoard Tabelle/Abfrage

Antworten: 5
Aufrufe: 2599
Letzter Beitrag Oktober 03, 2010, 16:45:38
von oma
Unzulässige Verwendung von Null

Begonnen von JunoBoard Access Programmierung

Antworten: 1
Aufrufe: 3328
Letzter Beitrag Oktober 07, 2010, 10:45:22
von DF6GL
Index beim Öffnen eines Ergänzungsformulars auf "Null" bzw. "leer" setzen

Begonnen von MisterSteveBoard Tabelle/Abfrage

Antworten: 7
Aufrufe: 4939
Letzter Beitrag September 21, 2015, 16:54:14
von DF6GL
Auto-Werte auf Null, bzw. nächsten Wert setzen

Begonnen von PergusBoard Access-Hilfe

Antworten: 9
Aufrufe: 7005
Letzter Beitrag April 05, 2011, 09:20:32
von DF6GL