Juni 15, 2021, 21:45:49

Neuigkeiten:

Ist euer Problem gelöst, dann bitte den Knopf "Thema gelöst" drücken!


Kopierter Bericht mit neue Datenquelle - Fehler

Begonnen von BikeArno, März 29, 2021, 15:56:59

⏪ vorheriges - nächstes ⏩

BikeArno

März 29, 2021, 15:56:59 Letzte Bearbeitung: März 29, 2021, 16:04:09 von BikeArno
Hallo,

ein Problem, welches ich bisher immer durch Mehrarbeit umschifft habe, nervt mich zunehmend:

Und zwar erstelle ich mehrere identische Berichte, die auf separaten Datenquellen beruhen.

Ich habe einen exemplarischen Bericht als Vorlage erstellt, diesen dann kopiert und im Eigenschaftenblatt die Datenquelle sowie den Steuerelementinhalt der jeweiligen Felder korrekt eingestellt. Ist ja alles selbsterklärend.

Dennoch kommt es in einigen Fällen vor, dass der zu öffnende Bericht Parameteranfragen anzeigt, obwohl betroffene Felder korrekt im Steuerelementinhalt auf die neue Datensatzquelle eingestellt sind. Selbst wenn ich diese Felder lösche, kommen die Paramterabfragen.

Gibt es im Berichtsentwurf eine Möglichkeit (analog SQL-Fenster in Abfragen), den Fehler zu finden bzw. zu korrigieren?

Danke und Gruß



PhilS

Die Berichtseigenschaften für Filtern, Sortieren und die Gruppierungen sind die "üblichen Verdächtigen", wo sich Bezüge auf geänderte Feldnamen gern verstecken.

Unser kommerzielles Find and Replace Tool kann eine große Hilfe dabei sein, solche "versteckten" Abhängigkeiten aufzuspüren.
Access DevTools - Find and Replace
Komfortables Suchen und Ersetzen in den Entwurfseigenschaften von Access-Objekten. In Abfragen, Formularen, Berichten und VBA-Code - Überall und rasend schnell!