November 25, 2020, 09:00:06

Neuigkeiten:

Wenn ihr euch für eine gute Antwort bedanken möchtet, im entsprechenden Posting einfach den Knopf "sag Danke" drücken!


Bericht: Datenquelle anzeige & schliessen sehr langsam, unter anderem

Begonnen von Walterio, August 06, 2019, 11:06:20

⏪ vorheriges - nächstes ⏩

Walterio

Hallo! Bitte um Hilfe:
Neuer LapTop mit Windows 2010, Access 2010 neu installiert.
DB wurde von einem anderen Gerät kopiert.
Öffnen und Schliessen eines Berichts in der Entwurfsansicht dauert sehr lange (anderes funktioniert normal). Ebenso verhält es sich bei der Auswahl der Datensatzquelle und nach Beenden vom Abfrage-Generator. Dachte zuerst es läuft gar nichts mehr und habe die Task (mehrmals) beendet. Erst als ich pausenmässig das Gerät alleine lies, war dann der Abfrage-Generator da.
Ich kann mir das überhaupt nicht erklären. Weiss jemand an was das liegen kann?
Der Aufruf von Formulare, Tabellen-Ansicht,.... alles normal.
Auf beiden Systemen läuft Access 2010. Muss ich irgendwie noch Updates runterladen?
Und, ja: Im alten System war Access auf Deutsch installiert, im neue ist es Englisch. Kann es daran liegen? Muss ich alles was mit dem Ausdrucksgenerator erstellt wurde nochmals editieren?
------
Genauer: öffnen eines Berichtes im Design-Modus = sofort!
öffnen von weiteren Berichten im Design-Modus: mehr als 2 Minuten Waretn.
schliessen: ebenso.
Habe neue DB erstellt und Tabellen und Berichte importiert -> keine Besserung...

DF6GL

Hallo,
besitzt der Bericht ein Abfrage als Datenherkunft?
Wie umfangreich ist diese Abfrage? Wie schnell wird diese Abfrage ausgeführt, wenn sie direkt geöffnet wird?
(Beim Anzeigen der Abfrage bis zum Ende scrollen!)

Walterio

Hallo DF6GL,
Nein, der Bericht basiert auf Tabellen (3), also eine Berichts-Interne Abfrage.
Und, wenn du meine Ergänzung gesehen hast, geht es vor allem um das öffnen von Berichten im Designmodus...

DF6GL

Hallo,

ich habe schon verstanden....


Du beantwortest aber nicht die Frage nach der Anzeigegeschwindigkeit der Berichtsabfrage.

Auch im Berichtsentwurf wird, warum auch immer MS das so gelöst hat, die Abfrage immer wieder bei Änderungen, bzw. Umschalten ausgeführt....

Langsames Ausführen deutet auf schlechte/unzureichende Verwendug von Indizes hin...

Zeige mal den SQL-String der Abfrage..

Walterio

Hallo DF6GL,
(Sorry, war weg) Danke für die Rückmeldung. Das Problem ist ja ist offensichtlich eines von Access, da es auf dem alten System (ein seeehr langsam gewordener Lenovo) so nicht Auftaucht. Habe weitere Versuche gestartet:
1. Öffnen eines Objektes (von welchem Typ auch immer, z.B. Tabelle) in der Entwurfsansicht geht normal ruckzuck.
Weiteres öffnen der Entwurfsansicht irgend eines anderen Objektes (Tabelle oder Bericht oder ...): mehr als 2 Minuten Wartezeit!
Und eben, in der Entwurfsansicht: Aufruf der Datensatzquelle dauert auch "eine Ewigkeit"...

trebuh

Hallo,

Eine Frage...
Hast Du auf dem anderen Laptop auch Windows 10 installiert, oder ist da Windows 7, oder XP istalliert?


Walterio

Problem taucht nicht mehr auf: habe mehrere Aktualisierungen mit Lenovo Vantage durchgeführt.
Danke für die Teilnahme.

Nikolaus

@Walterio: Herzlichen Dank für die Lösung!!!
Ich wäre von selbst nicht auf die Idee gekommen, Lenovo Vantage zu installieren und für Updates zu nutzen. Ja, das ist die Lösung für Access 2010 unter Windows 10 Pro. in meinem Fall
Gruß
Niko