November 25, 2020, 09:12:23

Neuigkeiten:

Ist euer Problem gelöst, dann bitte den Knopf "Thema gelöst" drücken!


Probleme nach Windows 10 update

Begonnen von herb54, Oktober 18, 2020, 18:54:20

⏪ vorheriges - nächstes ⏩

herb54

Hallo,

ich habe letzte Woche ein ziemlich großes Windows update heruntergeladen. Seit dem habe ich Probleme wenn ich ein Accessprogramm verändere und danach wieder öffne. Es kommt eine Fehlermeldung beim Öffnen des Programmes:
"Sie haben als Einstellung der Ereigniseigenschaft den Ausdruck ... ".
Das Problem liegt nicht am Accessprogramm. Auf einem anderen Rechner läuft es einwandfrei. Wenn ich dieses Programm dann von einem anderen Rechner wieder auf den Rechner mit dem Update übertrage kann ich es wieder öffnen.
Ich hatte diese Fehlermeldung vor Jahren schon einmal. Damals war die Ursache ein fehlerhafter Registrierungsschlüssel nach dem Update. Ich habe hier jedoch keinen Fehler gefunden. Hat jemand eine Idee was das sein könnte?
Vielen Dank!"
Herri

DF6GL

Hallo,


ZitatDas Problem liegt nicht am Accessprogramm

Das würde ich zunächst nicht gänzlich ausschließen...


Öffne den VBA-Editor und prüfe, ob in JEDEM Modulkopf  "Option Explicit" steht. Korrigiere das und Debugge/Kompiliere anschließend den Code.  Sollten Fehler auftreten, müssen diese allesamt eliminiert werden.


Zudem sind die Verweise zu prüfen, ob die nicht evtl. "gebrochen" sind.

Wenn ocx-Steuerelemente verwendet werden, ist die Registrierung der entspr. Bibliotheken zu prüfen, bzw. nochmal zu wiederholen. Danach ebenfalls kompilieren.

 

trebuh

Hallo Herri,

Frage: Mit welcher Windows und Office Version arbeitest Du?

Probier mal eine Reparatur der Office-Software.

Bei mir traten vor kurzem auch Probleme auf (Ich arbeite mit Windows 10 und Office 2010).
Ursache war die Office-Version, welche in Windows 10 vorinstalliert war.
Nach der Deinstallation dieser Version, konnte ich in Access gar nicht mehr auf den VBA-Editor zugreifen.
Nach einer Reparatur von Office 2010 war dann alles wieder behoben.

Gruß
Hubert

herb54

Hallo zusammen,

vielen Dank für eure Hilfe! Ich arbeite mit Office 2013 und Windows 10. Das Access Programm läuft eigentlich schon sehr lange fehlerfrei auf einem externen Server. Was halt merkwürdig war: Auf dem Server konnte ich das Programm einwandfrei öffnen nur auf dem eigenen PC nicht (und das nach einem Windows Update). Ich habe jetzt dieses Update wiederholt (Windows 10, Version 2004). Das dauerte fast 3,5 Stunden. Danach war alles wieder ok und ich konnte die Datei öffnen. Ich vermute fast, dass das Update nicht richtig installiert war (evtl. nicht vollständig). Was auch seltsam ist: Im Updateverlauf erscheinen jetzt keine anderen Updates mehr nur noch das jetzige (seltsam).
Hallo Franz was mich interessieren würde: Wie erkenne ich ob ein Verweis nicht mehr richtig funktioniert? Kann das zu dieser Fehlermeldung führen? Wie behebe ich fehlerhafte Verweise (einfach Häkchen entfernen und wieder setzen)?
Gruß
Herri

DF6GL

Oktober 21, 2020, 08:23:15 #4 Letzte Bearbeitung: Oktober 21, 2020, 08:28:57 von DF6GL
Hallo,

Windows Version 2004 ist eine (nahezu) vollständige Neuinstallation von Windows  ("Funktionsupdate"), nicht nur ein kleiner Patch von verschiedenen Dateien.

ZitatWie behebe ich fehlerhafte Verweise (einfach Häkchen entfernen und wieder setzen)?

genau so...  Anschließendes Kompilieren nicht vergessen.



Hast Du die Hinweise zu "Option Explicit" und Kompilieren beachtet?

herb54

Hallo Franz, vielen Dank für den Hinweis mit der Version 2004. Deshalb hat das Ganze auch so elend lange gedauert.
Das Programm läuft seither wieder einwandfrei. Das mit der Variablendeklarationsüberprüfung muss ich noch mal genau anschauen. Ich vermute aber, da gibt es einige Funktionen wo das fehlt!
Nochmals vielen Dank!
Herri