Januar 24, 2021, 04:01:55

Neuigkeiten:

Wenn ihr euch für eine gute Antwort bedanken möchtet, im entsprechenden Posting einfach den Knopf "sag Danke" drücken!


Bedingte Formatierungen nach Speicherortwechsel ohne Funktion

Begonnen von L_Ey, Januar 13, 2021, 16:49:57

⏪ vorheriges - nächstes ⏩

L_Ey

Guten Tag Zusammen,

nach Fertigstellung meines Access Projektes habe ich den Speicherort geändert.(kopiert)

Beim öffnen der neuen, als auch ursprünglichen Datei sind plötzlich die bedingten Formatierungen ohne Funktion.

Ich habe 3 Formulare, bei 2 davon funktioniert alles ohne Probleme. Beim 3. sind alle Formatierungen drin, allerdings werden diese nicht angezeigt.

Am Ausdruck liegt es nicht, da es vor dem Speicherortwechsel funktionierte.Die Formatierung prüft nur, ob eine Zelle 0 ist und färbt dann grün. Verlinkungen zu externen Daten gibt es in der gesamten Datenbank nicht.

Zellenhintergrund steht nicht auf transparent.

Ich habe es bereits über "Datei" --> "Datenbank komprimieren und reparieren" versucht, einen neustart gemacht und die Bedingungen gelöscht und neu angelegt.

Alles erfolglos.

Hat jdm eine Idee, woran es liegen könnte?

Vielen Dank und Viele Grüße

DF6GL

Hallo,

Zitat...habe ich den Speicherort geändert...

Der neue Speicherort muss in den Sucherheitseinstellungen (Trustcenter) in die Liste der vertrauenswürdigen Speicherorte aufgenommen werden.

Weiter Einstellungen dort sind auch zu prüfen.


L_Ey

vielen Dank für die schnelle Antwort.

Das hat bewirkt, dass ich meine Links jetzt ohne Sicherheitswarnung öffnen kann. Also eine anderweitige Optimierung.

Zum Thema bedingte Formatierung hat es allerdings nichts genützt.

In der Zwischenzeit kann ich aber detailieren.

Wenn ich in den Entwurfsmodus gehe und ein neues Steuerelement hinzufüge und wieder lösche ist die bedingte Formatierung plötzlich wieder funktionsfähig. Speicher und Schließe ich die Datenbank und öffne sie anschließend neu ist alles beim alten und nicht funktionsfähig.

Vielen Dank und viele Grüße
L_Ey


DF6GL

Hallo,

schwierig, hier Ferndiagnose zu treiben..

Lad die Db mal hier hoch, wie üblich datenreduziert, komprimiert/repariert und gezippt....


Und nenne Windows- und Office-Version

L_Ey

Vielen herzlichen Dank für das Angebot.

Leider ist das auf Grund sensibler Daten nicht möglich.

Windows Version ist Windows 10
Office ist 2016

trebuh

Hallo.

Werden die Daten in dem Formular aus einer Abfrage gelesen?
Kannst mal im Entwurfsmodus des Formulars die Abfrage öffnen und da nachsehen, ob die Daten korrekt angezeigt werden.
Eventuell die Datensatzherkunft neu herstellen?

Gruß
Hubert

DF6GL

Hallo,

man könnte ja unsensible Daten verwenden....


Versuch noch folgendes:

Neue leere DB(-Datei) erstellen und alle Objekte aus der alten importieren..



L_Ey

Zitat von: DF6GL am Januar 14, 2021, 13:58:56Neue leere DB(-Datei) erstellen und alle Objekte aus der alten importieren..


Das hat funktioniert, woran es gelegen hat bleibt unklar. Hauptsache es funktioniert jetzt, Vielen Dank. :)