collapse

* Benutzer Info

 
 
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?

* Wer ist Online

  • Punkt Gäste: 60
  • Punkt Versteckte: 0
  • Punkt Mitglieder: 0

Es sind keine Mitglieder online.

* Forenstatistik

  • stats Mitglieder insgesamt: 14419
  • stats Beiträge insgesamt: 71647
  • stats Themen insgesamt: 9667
  • stats Kategorien insgesamt: 5
  • stats Boards insgesamt: 17
  • stats Am meisten online: 415

Autor Thema: kein LostFocus bei mehreren Ufos  (Gelesen 185 mal)

Offline jagger

  • Access-Profi
  • **
  • Beiträge: 147
kein LostFocus bei mehreren Ufos
« am: Mai 20, 2019, 19:58:37 »
Guten Abend,

in einem HF gibt es mehrere Ufos.
Wenn ich von einem Ufo (Textfeld) ins andere Ufo (Textfeld) klicke,
wird kein LostFocus ausgelöst.
Ich habe zwei Varianten probiert:
LostFocus beim (U)Formular, LostFocus beim Textfeld.
Ich habe auch das Gefühl, dass der Cursor im
alten Ufo "kleben" bleibt, denn das angklickte Textfeld
(Hintergrund transparent) verliert nicht seine Hintergrundfarbe,
wenn ich in ein anderes Ufo klicke.

Kann man dieses Verhalten beeinflussen?

LG
jagger
 

Offline jagger

  • Access-Profi
  • **
  • Beiträge: 147
Re: kein LostFocus bei mehreren Ufos
« Antwort #1 am: Mai 24, 2019, 13:28:59 »
Hallöchen,

ich habe zu diesem Verhalten leider noch keine Erklärung gefunden.

Das Problem habe ich wie folgt gelöst:
Im Formularkopf von jedem Formular in den Ufos
habe ich ein Textfeld 0x0cm angelegt (sprungfeld).

Beim Klickereignis in den Textfeldern im Detailbereich
der Formulare in den Ufos habe ich dann als letzte Anweisung
"Me.sprungfeld.SetFocus" eingetragen.

Diese Aktion löst dann das Ereignis "LostFocus" bei den Textfeldern in den Ufos aus.

Allen noch ein schönes WE
LG
jagger
 

Offline PhilS

  • Global Moderator
  • Access-Meister
  • *****
  • Beiträge: 594
    • Tipps zu Access, VBA, SQL und Co.
Re: kein LostFocus bei mehreren Ufos
« Antwort #2 am: Mai 24, 2019, 14:36:48 »
ich habe zu diesem Verhalten leider noch keine Erklärung gefunden.
Hier ist sie:
Zitat
Wenn Sie den Fokus von einem Steuerelement eines Unterformulars zu einem Steuerelement des Hauptformulars verschieben, treten nicht die Ereignisse Exit und LostFocus für das Steuerelement des Unterformulars, sondern nur das Exit -Ereignis für das Unterformularsteuerelement und die Ereignisse Enter und GotFocus für das Steuerelement des Hauptformulars auf.
Quelle: https://docs.microsoft.com/de-de/office/vba/api/access.textbox.lostfocus
 
Folgende Mitglieder bedankten sich: jagger

Offline jagger

  • Access-Profi
  • **
  • Beiträge: 147
Re: kein LostFocus bei mehreren Ufos
« Antwort #3 am: Mai 24, 2019, 15:40:46 »
Hey PhilS,

Danke für den Link.

LG
jagger
 

 

Tage auslesen, zu welchen kein Datensatz existiert

Begonnen von mradlmaierBoard Tabelle/Abfrage

Antworten: 4
Aufrufe: 4286
Letzter Beitrag Mai 11, 2010, 20:49:18
von mradlmaier
Kein Handcursor obwohl "Ist Hyperlink" auf ja steht!!!

Begonnen von shadockBoard Formular

Antworten: 2
Aufrufe: 2379
Letzter Beitrag Juli 03, 2010, 00:00:27
von oma
Kein Druck bei leerem Feld

Begonnen von EDVHILFEHRBoard Bericht

Antworten: 2
Aufrufe: 3062
Letzter Beitrag Juli 14, 2010, 10:39:16
von DF6GL
Kein 'OutputTo' möglich, wenn Symbolleiste nicht vorhanden

Begonnen von micheligBoard Access Programmierung

Antworten: 12
Aufrufe: 8508
Letzter Beitrag Mai 31, 2011, 22:09:19
von michelig
Problem für das ich kein Betreff finde....

Begonnen von pjo12345Board Access Programmierung

Antworten: 1
Aufrufe: 3020
Letzter Beitrag Mai 11, 2011, 09:23:51
von DF6GL

Advertisment / Werbung - Amazon Affiliate Links